Debit Card / CardValet Issues
Incident Report for MutualBank
Resolved
All of these issues with debit cards should now be fixed. Thank you.
Posted about 2 years ago. Sep 26, 2017 - 10:50 EDT
Monitoring
Most customers should be able to use services without issue but we are still working on resolving every issue. We hope by 5:30PM to have all resolved. Thank you.
Posted about 2 years ago. Sep 25, 2017 - 16:18 EDT
Investigating
Due to some technical issues with our core processor, some customers may be experiencing challenges with debit card activation, the CardValet app, and some cards defaulting to limits of $100 for ATM transactions and $500 for point of sale transactions. We are working to resolve this ASAP and hope to have updates for you soon.
Posted about 2 years ago. Sep 25, 2017 - 12:19 EDT