Debit Cards Issue
Incident Report for MutualBank
Resolved
This issue has been resolved and cards should be functioning normally. Thank you for your patience.
Posted about 2 years ago. Jul 28, 2017 - 11:13 EDT
Identified
The issue appears to be with our debit card provider as it is affecting their other clients as well. They are investigating and hope to have it fixed soon. More updates to come.
Posted about 2 years ago. Jul 28, 2017 - 10:49 EDT
Investigating
We have learned that for many of our customers, their debit cards are not working at point of sale or ATM transactions. We are investigating the issue and will resolve the issue as soon as possible.
Posted about 2 years ago. Jul 28, 2017 - 10:41 EDT