Direct Deposit Issues
Incident Report for MutualBank
Resolved
This issue has been resolved and most if not all direct deposits should be processed. Thank you.
Posted almost 2 years ago. Dec 01, 2017 - 12:03 EST
Investigating
Due to technical issues, some customers are reporting that their direct deposits are not posting to their account. Deposits are indeed posting but are doing so very slowly. We hope to have this issue corrected and updates for you ASAP.
Posted almost 2 years ago. Dec 01, 2017 - 09:35 EST