Personal & Business Online/Mobile Banking are Unavailable
Incident Report for MutualBank
Resolved
This issue has been resolved and everything should be functioning as normal. Thank you for your patience.
Posted 5 months ago. May 28, 2019 - 13:27 EDT
Update
We are continuing to work on a fix for this issue.
Posted 5 months ago. May 28, 2019 - 10:14 EDT
Identified
We are aware that users may be experiencing intermittent access to Personal & Business Online and Mobile Banking. Users may receive the "We are having technical difficulties logging into the application. Try again later." error message. Mobile app users may receive the "We are unable to validate your information. Please try again or check that your login credentials are set up correctly in online banking.” error message. Technicians are researching this event and we will provide an update as information becomes available, or by 10:30 A.M. Eastern Time.
Posted 5 months ago. May 28, 2019 - 10:12 EDT
This incident affected: Mobile Apps (Apple iOS App (Personal), Android App (Personal), Apple iOS App (Business), Android App (Business), Mobile Check Deposit) and Online Banking (Personal Online Banking, Business Online Banking, eStatements, Check Images).