Online Bill Pay Unavailable
Incident Report for MutualBank
Resolved
Bill Pay is now fully functional. Thank you.
Posted almost 2 years ago. Dec 01, 2017 - 14:35 EST
Investigating
users are currently unable to access Bill Pay through Retail Online, and they are receiving the error message, "Application error: We are having technical difficulties. Log in again later." As a temporary workaround, users may use the MutualBank app to access Bill Pay. Technicians are identifying the cause of the error message and are working to restore Bill Pay.
Posted almost 2 years ago. Dec 01, 2017 - 12:06 EST